(Solved)How to connect an MQTT external device to TagoIO dashboard

Hello Support Team! i am new to TagoIO and trying to get acquainted with it. I have created a device with custom MQTT connector, but don’t know how to setup next and unable to make it work this external device with TagoIO. Please assist me further to fix this issue to keep continue with TagoIO. Thanking you.

A common hurdle is to connect to the platform for the first time.
For that reason we have created a lab https://mqttlab.iotsim.io/tago to get started in minutes,
not hours or days. It is a starting point to learn how to connect to Tago quickly and explore its


Hello Gambitcomm! Thanks for your reply to my mentioned problem. I appreciated it. Please let me give sometime to review on your provided link to fix this issue. Thanking you.

1 Like

The documentation at TagoIO for MQTT was also improved to help with connecting MQTT devices: MQTT - TagoIO

Hello Vitor! I’ll review on this. Thanks for keep supporting.

Hello Vitor! I’m unable to connect my device to Tago MQTT broker. As you know first i made it to connect, now its not connecting at all. Did you upgrade your Tago MQTT broker server login parameters? Please update with the new connect details for the following to be entered at device end:

MQTT Broker Host Server: ?
Client ID: ?
Port: ?
Username: ?
UserPassword: ?

Thanks for keep supporting.

It seems to be working normally here. Are you sure it is not an issue on your side?
Maybe you did delete your token, and it changed to a new token.

Hello Vitor,

Okay! Here is my device settings:

MQTT Broker Host Server: “mqtt.tago.io
Client ID: “85e950ea-a1d6-4c0e-acb1-7728d1c5fff3”
Port: 1883
UserPassword: “85e950ea-a1d6-4c0e-acb1-7728d1c5fff3”

Please let me confirm that above settings are correct at my device end to connect to the Tago MQTT broker?

It seems that you deleted the bucket from your device. Without bucket, the device can’t be used to receive data or for MQTT connection.

Hello Vitor, Yes! i think you are right, i have deleted the bucket and after that the problem created. Let me check whether creating the bucket will fix the connectivity issue or not.

Secondly, you didn’t confirmed me yet that whether my Tago MQTT broker settings are correct at the device end or not?

Thanking you.

It does seem correct for me.

Okay! let me check with creating bucket and get back to you. Thanks for keep supporting.

Hello vitor, I have created bucket for the device and tried to connect the Tago MQTT broker host, but didn’t connected at all. While tested with other public MQTT brokers it works and connect fine without issuing an error.

Here is the error msg:

>>> client = MQTTClient('85e950ea-a1d6-4c0e-acb1-7728d1c5fff3','mqtt.tago.io')
>>> client.connect()
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/lib/umqtt/simple.py", line 194, in connect
IndexError: bytes index out of range

No error at all with this MQTT broker:

>>> client = MQTTClient('mqttx_5df106d9','broker.emqx.io')
>>> client.connect()

No error at all with this MQTT broker:

>>> client = MQTTClient('52dc166c-2de7-43c1-88ff-f80211c7a8f6','test.mosquitto.org')
>>> client.connect()

I think there is some issue with your MQTT broker to avoiding to connecting the device to it.

Which MQTT version you’re using as client? The error you’re receiving seems a problem with MQTT version packets.

Hello Vitor, I have fixed the issue and my device get connected again with Tago platform. Now let us get started from where we have left to dashboard data visualizing issue. Please refer to the topic Unable to visualizing real data on Dashboard. Thanks.