Sigfox Downlink NO_ANSWER

Hi Tago Community,

I’ve got a Sigfox device that I need to send donwlink data to. I have set it up according to the documentation but I am getting a NO_ANSWER status.

No answer

I have included snapshots of my setup below:

Callback

Config Parameters

When the device sends a downlink request the parameter shows that it has been read.

I have tried this with several devices and not succeeded. I have a payload parser active, I’m not sure if this will effect the downlink.

Thanks in advance.

Nick

Hi @nicholass,

It seems all right.
Are you receiving the uplink for this device?
Do you have two (2) callbacks on Sigfox backend? One for uplink and another for downlink.

Can you share your profile with me? my email is eger@tago.io see here how to share your profile. Let me know when you share.
You can remove my access after we resolve your issue.

Hi Eger,

I am receiving the uplink for this device, and this device type only has one uplink and one downlink associated with it.

I have shared my profile with you.

I saw your account and it looks all right.

Downlinks are being sent as well. The payload is in the configuration of the parameter of your device (as in the image below). The downlink is sent only once and the key is marked as ‘read’, if you request one more downlink and the parameter key is ‘read’, we will respond with a ‘no content’ for Sigfox.

So if you’re getting no response on sigfox it’s because your downlink parameter is ‘read’, you need to mark the parameter as ‘unread’.

Every time that a downlink is sent we change automatically the parameter to ‘read’, and if you want to send again you must back the key to ‘unread’.

Thanks for checking this Eger,

I am aware that it works in this way, I have set it several times back to unread but I still get the same situation described above. This is what is confusing me, the indicator changes from ‘unread’ to ‘read’ yet I get a NO_ANSWER response.

I have multiple devices in the device type, they all use the same downlink. Is it possible that when other devices in the device type request downlink this changes to ‘read’?

No, each device has a Sigfox ID, so the downlink is always sent to the ID that matches the Sigfox request.

Thanks Eger,

I set it back to “unread” yesterday. Today after the downlink was requested it went to “read” but still no answer.

My device also shows that it has never sent an output, shouldnt that show the time of the last downlink response?

image

Nick

Hi Eger,

Am I supposed to receive a downlink message in the Live Inspector, I only received the uplink payload.

@nicholass,

If your parameter is marked as read, it means that we sent to Sigfox your downlink. I suggest you contact their support or check your device manufacturer this question.

1 Like