Show last update not on display

I have created a blueprint dashboard, and have a number of widgets where “show last update” is enabled. On my iphone on TagoRun, it shows as I would expect (last update in bottom right of widget). However I have some clients with iphones where the last update is not showing. Haven’t tested with android at all. Is there a way to fix this?
On another note, it it possible to have a widget just to show the last update time?
Thanks in advance, Andrew.

I have the same problem, the last update is not updating on the display widget on a blueprint dashboard.

@alinetusi

Apologies, there is an option in the settings (on run app) on iphone that enables this to show.
Still curious as to whether this can be done…is it possible to have a widget just to show the last update time?
Similar to this…image

Hi @sevils

Yes you have an option in the mobile app -> settings.

To show the last update value in the widget value you will need to save in a separate variable for example last_update the value of the current time using for example momentjs or dayjs whenever you update the wanted variable in the analysis.

If you’re using or if you can make use of the dynamic table widget, you can also enable the option of show the time column, which will appear the current time of the line.

time

Remembering that you can always enable the “Show last update” option and it will be appear right beside the widget title.

Thank you,
Guilherme Oliveira

Hi @sanimesa

Can you be more specific?

  • In the Desktop or in the Mobile App?
  • In which widget are you having problem?

@guilhermeco

  1. create a display widget on a blueprint dashboard
  2. Set the Show last update to on.

You will notice that the Last updated on the header is not updating unless you leave the page and come back, this is unlike other widgets. I only saw it on desktop though.

Thanks.

Hi @sanimesa

Thats strange, I’ve just tried in my computer and it is working. Could you please try to delete the widget and re-add it? Also make sure that the variable is being update so the widget can show it.

Hi @guilhermeco
how do you turn on Last update time on Widgets displayed on a normal dashboard using a PC not the app. It appears on my dashboard just not the dashboard of someone that I have shared the dashboard with ?. I am the original developer for that dashboard.

Thanks

Hi @samhain
I think that we dont have the “last update” feature on the normal dashboards widgets. Can you share a screenshot on where did you find that?

Thank you!

Hi @samhain,

I’m aware of what you’re talking to, I’m just not sure if that’s available on the normal dashboards as I cant find on mine, can you printscreen where are you enabling “show last update” option? On the blueprint dashboards I can assure you this is working, which has this featuring working properly.

Hi @guilhermeco that is the part that I can not find, nowhere can I find the" Enable last updates" but they show up on my dashboard when I created them but not on the dashboard of someone that I shared the dashboard with this is the problem I need them on the other persons dashboard also.

Hi @samhain,
I just tested on my Iphone and it seems to be working.

Also, you can have a widget to show the last update. Just pick any variable that is commonly updated on your device and enable the Formula for the variable.

In the formula you must enter $TIME$.
It will pickup the time parameter of the data instead of the value, and it will show it instead.

image

1 Like

Hi @guilhermeco,
I have no problem with it displaying last update on any mobile device it is just not showing up when someone else uses a PC and web browser to display the shared dashboard rather than the app ?.