How to integrate TagoIO with Swisscom LoRaWAN NS

Here is a quick tutorial showing how to add any LoRaWAN device through the Swisscom NS (Network Server). By following this tutorial, your setup will be ready to perform uplink and downlink operations (data from and to your end-point devices). For this, you need to access your account at Swisscom Administrator console.

1. First go to your TagoIO account, and if this is your first device connected between Swisscom and TagoIO, you will need to create an Authorization here . Copy it to use at Swisscom later.

  • Note : you need to create only one Authorization by account. It works for all your devices.

2. Go to your Swisscom console and create a new Application. You can create a new application under the menu Application Servers > + Create > Select HTTP Application Server (LoRaWAN).

In the application server section, change the following fields to:

  • Content Type: JSON
  • Status: Active

In the Add route section, press the button + Add.
Fill the fields accordingly:

In the Uplink/downlink security section, click in the button Activate.
Fill the fields accordingly:

  • AS ID: tagoio
  • Tunnel Interface Authentication Key: Generate a random one and copy to use TagoIO in step 4.
  • Max timestamp deviation: 30

Press save in the up corner to save all your settings.

3. Now you need to create an AS routing profile. Click on it in your sidebar at Swisscom console, and then click in the + Create button.

Enter a name and select the type LoRaWAN. Create it and click to edit if you weren’t redirected automatically to the profile page.

  • Set the AS routing profile Is default: true.

Create a new destination by clicking in the + Add button.
Fill the fields accordingly:

  • Type: Local application server
  • Destination: Choose the Application server you created in step 3.

Press save in the up corner to save all your settings.

4. Go back to your Authorization page at TagoIO, edit your previously created authorization by clicking in the pencil button. Paste the Tunnel Interface Authentication Key generated at Swisscom.

5. Now, you just need to start adding Device in your TagoIO account.
Go to Devices/LoraWaN Swisscom, and choose the device connector from the list. Enter your device EUI - you can use the QR code to capture the EUI.

  • Note: if the device that you are looking for connecting with TagoIO is not in the list, you can always select the Custom Swisscom option and you can add the Parser for it later.

:grinning:Done! Just turn your device and gateway on, and you will see data arriving in your account (data bucket of the device). Start building your dashboards, analysis, and actions!
If data doesn’t show up in your TagoIO account (use the Live Inspector tab in your Device to see data arriving), make sure you can see data in your Swisscom console first, and check the keys and the configuration.

Hi Vitor
Many thanks for this guide! I am in the progress of trying to set up the Tago-Swisscom Integration. On the Swissom’s side everthing’s clear so far. But on the side of Tago I cannot add a device with the LoRaWAN Swisscom connector you mentioned as it doesn’t seem to exist for me. I am aware that this integration is very new and maybe the connector is not even published yet. I just want to make sure that I am not missing something.
All the best, Nico

Hi @nico,
The tutorial was released, but the network is still in internal testing.

I’ll let you know when it’s available to use.

Hi @vitor, alright then. Can you give me some approximate roadmap when it is planned to be released? Next weeks or could it take even longer?

Edit: I saw it is already released!


I just tried the integration with Swisscom. Uplink works fine. I receive packets from my device over Swisscom in TagoIO.

I currently struggle with downlink function. I used the “Sending Downlink from Dashboard” example. The Dashboard triggers the analysis script, but the script finishes with a 404 Error.

In the script I get from the network object the middleware_endpoint parameter. The URL, which I get, in the middleware_endpoint is: This is the exact URL of this Forum Post!

Is there something I do wrong? Or what is the correct middleware_endpoint URL?

Hi Marco,
Thanks for reporting this to us. I just fixed the link on the Swisscom connector.


Hi Vitor

Now it is working :smiley: Thanks for the quick fix.