Dashboard Formula $TIME$

I’m using TIME in the formula section to show the time stamp of a data field.
Unfortunately it’s in US format and I need UK.

Is it possible to use some formatting commands within the formula field. In fact what is allowed in this field?

Thanks

Hi @tago,
The data format cames from your account, so you need to configure it there, follow the steps below:
Go to your account, click on the Visualization Preferences tab, then select the date format that you want.

See you! :v:

Hi. I have checked the accounts setting and it is already set to UK format.
Perhaps the TIME variable is pre-formatted?

OK, that’s weird. I changed my DD/MM/YYYY to YYYY/MM/DD and that worked, then changed it back to DD/MM/YYYY and now the TIME value respects this format correctly. Perhaps there was a bad default setting in the database.

However, that’s on the dev account. When I view the Dashboard as a user via Run the format reverts to US format. I have checked the users account under User Management and there is no place to change the Visualization Prefs.

Any idea?

OK. I sorted it.
Initially I was viewing the user account in IOS.
I logged into that run instance on a browser as the user and the date format was US format as per the IOS view.

However, the format shown on the Vis. Pref for that user account was DD/MM/YYYY.
I changed to MM/DD/YYYY, Saved, then back to DD/MM/YYYY, Saved.

The web version and the IOS version of the dashboard are now correctly showing UK format.

However, it looks like there is a problem in the underlying user creation defaulting to US format but incorrectly showing UK format preference. I’ll do some more tests.

Thanks

I can confirm that a different user account on the same Run instance has the same problem.

  • US date format used on Dashboard
  • UK date format shown on User Vis Prefs
  • I tried just re-saving the Vis Prefs without any change but this doesn’t change the Dashboard US format.
  • Confirmed that I have to change the Date Format to US or International, Save, then back to UK, Save.

Looks like a user creation issue.

Hope this helps.

Hi @tago,
Thanks for your notes.
I’m going to open an issue about this behavior on the TagoRUN. :+1:

Is there a public ‘issue’ list so we can see the current things being worked on?

Hi @arbelelectronics,
We only have a private issue list, however, I will post here when the fix is released. :slightly_smiling_face: